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Chapter 1

Main Concepts

Watermark Sense (http://veprit.com/watermarksense) is designed to make batch
image watermarking as flexible, fast, and easy, as possible. It releases you from
tedious redundant tasks that software can perform automatically. No need to de-
fine the same configuration twice: save it as a custom watermark preset, and reuse
it. Same with saving configuration: save it as a saving preset, and reuse. No need
to manually position the watermark in similar images twice: do it manually for
one image, and copy & paste it to other images (see Section 5.1).

The main workflow, outlined in detail in Chapter 3, is the following: import
images (Section 3.2), choose the operation mode (Section 3.3) and configure the
watermark(s) (Section 3.4), optionally preview the results and reposition water-
mark(s) manually (Section 3.5), and save the results (Section 3.6). Use watermark
presets to simplify the watermark configuration, and saving presets to simplify the
saving setup. You can also assign saving presets to watermark presets to get both
the watermark and saving configuration covered by the watermark preset! More-
over, you can even apply multiple watermark presets to every image in a single
run! After you have configured the watermark and saving presets, it is amazingly
easy to process hundreds of images, apply several watermarks to every image, and
save in different image formats with different file naming patterns, all in a single
run! All you need to do is import images, select watermark presets to apply, and
save. That’s it! You have done a huge amount of work!

Despite the powerfull batch processing capability, Watermark Sense is flexible
enough to enable a manual watermark positioning adjustment for every image, for
every applied watermark preset. Once the watermark has been configured, select
an image and position (move) the watermark manually. Keep in mind that the
manual positioning is applied to the current focus image (shown in the Preview)
and to the currently selected watermark preset. Watermark Sense also allows you
to copy the manual positioning settings between images.

In addition, Watermark Sense supports some common batch image editing op-
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erations. These are 90◦ and 180◦ rotation (Section 4.1), and horizontal and vertical
flipping (Section 4.2). Watermark Sense also supports batch image EXIF/IPTC
metadata editing.

When configuring a watermark (Section 3.4), always keep in mind that this
configuration is defined for multiple, not for a single, image. Unless you have very
specific size requirements, prefer using relative rather than absolute size units. For
example, define the watermark width in ”% of image width” rather than in pixels.
This way your watermark will look similar on images of different sizes.

Copyright c©2013-2014 VeprIT. All rights reserved.
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Chapter 2

User Interface Overview

Figure 2.1 presents the main Watermark Sense window and its parts.

Figure 2.1: Watermark Sense window overview.

The watermark configuration area defines the watermark(s) applied to all im-
ages. Image Browser (Browser) shows the imported (or filtered out with an active
filter) images. Preview shows the final image, and allows to manually reposition
the watermark for the current preset. Commands available in the toolbar are ap-
plied to all the images selected in Browser, not only to the one shown in Preview.
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Chapter 3

Main Workflow

This chapter describes every step in the intended Watermark Sense workflow.

3.1 Choosing Between Small and Large Batch Mode
Watermark Sense works in the Small Batch and Large Batch modes. If you are
working with a reasonably small number of images and wish to preview and pos-
sibly customize them individually, choose the Small Batch mode. When working
with many images mostly without customization, choose the Large Batch mode.

What exactly is ”a reasonably small number” and what is ”many” images de-
pends on your computer hardware and the size of the images, and thus cannot be
easily defined. Simply keep in mind that the Small Batch mode is designed for
the cases when you plan to individually preview and customize images (position
watermark manually, rotate, etc.). You are probably not going to do that with hun-
dreds or thousands of images. To set an upper limit, Watermark Sense does not
allow more than 500 images in the Small Batch mode. If you are adding more, it
will offer to switch to the Large Batch mode.

Switch to the desired mode, if it is not already active, in one of the following
ways:

• Click the toolbar button (to switch to the Large Batch mode) or (to
switch to the Small Batch mode).

• Use the menu View → Switch to Large Batch Mode or View → Switch to
Small Batch Mode.

• Press Cmd + B on the keyboard.

Copyright c©2013-2014 VeprIT. All rights reserved.
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3.1.1 Small Batch Mode
In the Small Batch mode, Watermark Sense loads all the images as soon as you
add them, and shows their thumbnails in the Browser. This is convenient when
you work with a reasonably small number of images, and need to preview and
possibly customize many of them. You will find what you need quickly with the
thumbnails, and Preview will work faster because the images are already loaded
to the memory. You can also save images by dragging them from the Browser
to Finder or another application supporting image dropping. In addition, because
images are loaded as soon as you add them, Watermark Sense will report possible
unsupported formats immediately.

However, the Small Batch mode is not recommended when working with
many images. Because all the images are loaded to the memory, the application
may seriously slow down your computer. In addition, importing many images
might take quite a long time.

Figure 3.1: Image Browser in the Small Batch mode.

3.1.2 Large Batch Mode
When you add images in the Large Batch mode, Watermark Sense does not load
them, but only remembers the file locations. Thus, adding many images happens
much faster than in the Small Batch mode. When saving, the images are loaded
and processed one by one, and are not kept in memory afterwards. This enables
you to process thousands of images without slowing down you computer.

However, Preview will likely work slower in the Large Batch mode, because
the image might not have been loaded yet. The metadata panel is not available in

Copyright c©2013-2014 VeprIT. All rights reserved.
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the Large Batch mode for the same reason. Also note that Watermark Sense might
not recognize all the unsupported image file formats until the images are saved.
This is because they may only be loaded when saving.

Note that when you preview, rotate, flip, or paste the manual positioning con-
figuration, target images must be loaded. Thus, it is not recommended to perform
these operations with many images (more than you would normally process in the
Small Batch mode).

Figure 3.2: Image Browser in the Large Batch mode.

3.2 Adding Images
Add images to Watermark Sense in one of the following ways:

• Drag items from another application supporting drag & drop functionality.

• Click the Add Images button .

• Use the File→ Add Images. . . menu item.

• Press Cmd + O on the keyboard.

In cases other than using drag & drop, the standard Open File panel will be
displayed. Choose the image files and/or directories and click the Open button.

Note that you can drag or select both individual image files and directories
with image files. When a directory is added, Watermark Sense scans all its con-
tents (including subdirectories) and adds all the image files.

Copyright c©2013-2014 VeprIT. All rights reserved.
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Also note that you can drag items not only from Finder, but also some other
applications. For example, you can drag & drop both individual images and com-
plete events from iPhoto.

3.3 Choosing Between Single and Presets Mode
Watermark Sense works in Single and Presets modes. Choose the corresponding
tab in the configuration area to select the mode .

Figure 3.3: Selecting watermark presets
to apply.

In the Single mode, a sin-
gle watermark configuration is ap-
plied to all saved images. This
configuration is technically the
same preset as any other custom
preset, and it is sometimes referred
to as Quick Preset. Unlike other
presets, Quick Preset gives you a
faster access to the watermark set-
tings, enabling to preview the re-
sult of any change immediately.
For your convenience, Watermark
Sense saves the last used Quick
Preset, so that you never have to
enter the same settings twice. You
can always save the Quick Preset
as a custom preset using the corre-
sponding button .
You can also load any existing pre-
set to the Quick Preset.

In the Presets mode, chosen
watermark presets are applied to
all the saved images. Depending
on the Combine all applied presets in every image checkbox state, every image is
saved either separately for each applied preset, or once with all the applied presets
combined. All the existing watermark presets are shown in the bottom list of the
Presets tab. You can filter them using the search field above to quickly find what
you need. Select the presets you want to apply and click the Apply Selected Pre-
sets button . The selected presets should appear in the list on the
top.

Order of the applied presets is important if the watermarks intersect each other.
You can drag applied presets to reorder them.

Copyright c©2013-2014 VeprIT. All rights reserved.
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For your convenience, Watermark Sense includes a number of example presets
to start with.

3.4 Watermark Configuration
To define and manage custom watermark presets, use the Manage Presets button
in the Presets tab, or the Window → Watermark Presets Management menu, or
press Shift + Cmd + P. You can also double-click a preset in one of the lists on
the Presets tab to edit it.

Figure 3.4: Watermark configuration.

Whether you are defining a
regular watermark preset (in the
Watermark Presets Management
panel) or the Quick Preset (in
the configuration area in Single
mode), you have mostly the same
configuration options.

First, you have to choose the
watermark type: text or image.
You cannot combine text and im-
age within one watermark pre-
set. However, you can com-
bine any watermarks, including
text and image ones, in the Pre-
sets mode (with the Combine all
applied presets in every image op-
tion checked).

For the image watermarks, the
Data tab defines the image to use
as a watermark. For text water-
marks it defines the text itself and
all its attributes.

Watermark Sense supports us-
ing various image EXIF/IPTC
metadata fields in the text water-
marks. The watermark text is de-
fined by a combination of pre-defined tokens and custom text. The custom text
will remain unchanged, while the pre-defined tokens will be substituted with the
corresponding values. The pre-defined tokens can be entered manually or inserted
using the popup button under the text field.

The available text attributes include the font, its size, alignment within the

Copyright c©2013-2014 VeprIT. All rights reserved.
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watermark area, text color, and stroke. Note that the Size field here defines a letter
height, not the watermark size. The watermark width is defined in the next tab
Size & Position.

Image- and text-specific configuration is completely covered by the Data tab.
The following tabs control various general watermark aspects, from its size and
position to visual presentation and effects.

Note that the watermark size is defined by its width. For image watermarks,
the height depends on the used image: it is computed to preserve the original
image aspect ratio. For text watermarks, the height depends on the used text. The
text of the previously configured size (letter height) is laid out within the given
horizontal bounds. The total watermark height depends on the number of lines
needed to fit all the text.

Most sizes, such as the text height, support both absolute and relative size
units. When using absolute units, you are losing flexibility. For example, if you
set the watermark width to 400 pixels, it will look very large on a 800 × 600
image, and quite small on a 4000 × 3000 image. Thus, unless you have very
specific absolute size requirements, using relative units is preferable. These are
percents of the image width and height, as well as percents of the short and long
image edges. Watermarks defined using relative units look similar on images of
different sizes and possibly orientations, thus your presets are more universal.

3.5 Previewing the Results
Once you have added images and defined the applied watermark presets, you can
preview the output images. In the Single mode, select an image in the Browser
to see its preview. In the Presets mode, select an image and one of the applied
presets (in the Applied Presets list) to see a preview.

3.5.1 Manual Watermark Positioning
If desired, you can manually reposition the watermark on any image, for any pre-
set (only works with disabled Combine all applied presets in every image option).
Simply drag the watermark rectangle in the Preview. Use the Reset manual posi-

tioning commands (or corresponding buttons ) to cancel the manual adjust-
ments for selected images. Note that there are two versions of this command: one
affects only the current preset (Quick Preset in the Single mode, or preset selected
in the Applied Presets list in the Presets mode), the other affects all presets.

To save time, you can copy & paste the manual positioning adjustment be-
tween images. See Section 5.1 for more details.
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3.5.2 Manual Positioning with Combined Presets
In the Presets mode, if the option Combine all applied presets in every image is
set, manual watermark positioning is disabled. However, you can still position
watermarks manually in the following way:

• Temporarily disable the Combine all applied presets in every image option.

• Select every applied preset you wish and position its watermark manually.

• Enable the Combine all applied presets in every image option again. The
manual positioning will be preserved.

3.5.3 Preview Controls
Space + drag – move the zoomed image.

Outside the watermark:

Click – zoom in the clicked point.

Option + click – zoom out from the clicked point.

Double-click – zoom the clicked point to the maximum. If already zoomed to
the maximum, zoom out completely (fit the image).

Inside the watermark:

Click and drag – reposition the watermark on the shown image (use the ”reset
manual positioning” commands to cancel).

Command + click – zoom in the clicked point.

Command + Option + click – zoom out from the clicked point.

Command + Double-click – zoom the clicked point to the maximum. If already
zoomed to the maximum, zoom out completely (fit the image).

Copyright c©2013-2014 VeprIT. All rights reserved.
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3.6 Saving Images
Save all the images shown in the Browser (if a filter is active, hidden images are
not saved) in one of the following ways:

• Click the Save All button .

• Press Cmd + S on the keyboard.

• Use the File→ Save All Images. . . menu item.

Alternatively, save only the selected images in one of the following ways:

• Click the Save Selected button .

• Press Shift + Cmd + S on the keyboard.

• Drag images from the Browser and drop them in Finder.

• Use the File→ Save Selected Images. . . menu item.

If only one image is being saved, the standard file saving panel is displayed,
extended with the image file format options. Choose the name, location, file for-
mat and other options, and click the Save button. Note that depending on the user
preference, the panel will by default open either in the last used directory, or in the
directory where the original image is. You can change this in Preferences: click
the Watermark Sense→ Preferences. . . menu or press Cmd + ,.

If multiple images are being saved, the Save Multiple panel is displayed. You
can choose between saving to a specified directory and the original location from
where you imported images (only specified directory in the Mac App Store ver-
sion, see Section 5.4 for more details).

Further you have the option to Replicate the original directory structure. If
selected, you define the starting point from where the directory structure should
be replicated. When saving files from sub-directories of this location, these sub-
directories will be replicated in the target location. Files originating at locations
outside the starting directory will be saved at the main output location, no sub-
directories will be created.

After that you define how the output image files should be named, and the
output image file format. These settings can be saved in saving presets, and as
such can be assigned to watermark presets. The option Ignore saving presets
defined in watermark presets allows you to choose if the settings defined below
in the Save Multiple panel take precedence over the saving presets assigned to the
applied watermark presets, or they are only used if no saving presets are assigned
to the applied watermark presets.

Copyright c©2013-2014 VeprIT. All rights reserved.
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Figure 3.5: Save Multiple panel.

Using the Saving presets but-
ton, you can load the file nam-
ing and format options from ex-
isting saving presets, save the cur-
rent settings as a new saving pre-
set, and manage the saving pre-
sets. When managing saving pre-
sets, you define the file naming
and format in the same way as
in the Save Multiple panel, as de-
scribed below.

The output filename is de-
fined by a combination of pre-
defined tokens and custom text.
The pre-defined tokens can be en-
tered manually or inserted using
the popup button under the in-
put field. In the output filename,
the custom text will remain un-
changed, while the pre-defined to-
kens will be substituted with the
corresponding values. The following tokens are defined:

filename – the original image file name.

watermark preset name – the name of the watermark preset which is being ap-
plied.

saving preset name – the name of the saving preset which is being applied.

width – the output image width.

height – the output image height.

sequence # – the output image sequence number. There are several options with
varying number of digits in the number. For example, sequence ### will
produce ”001” for the first image.

metadata fields – a number of IPTC and EXIF metadata fields.

When saving to the original location, make sure the output filename template
is not just the filename token. Otherwise you risk to overwrite your original image
files, and you will be unable to recover them unless you have a backup. For the
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same reason, when applying multiple watermark presets per image, make sure to
use some pre-defined tokens producing different results for all the applied water-
mark presets to generate unique output filenames. For example, use the watermark
preset name (assuming your presets have different names), or a sequence number.
In any case, if Watermark Sense discovers that any file will be overwritten when
saving, it will warn you, proposing to generate a unique filename, to overwrite, or
to skip saving this file.

When saving by dragging images to Finder, the last used Save Multiple con-
figuration is used.

Watermark Sense supports several output image formats: JPEG, TIFF, PNG,
GIF, and BMP. For JPEG, you can also define the image quality. The higher the
percentage for JPEG quality is, the better the image quality will be, and the larger
the file size will be. You can also choose to save in the original image format.
In this case, Watermark Sense will try to detect the original image format based
on its file name extension. If the detected format is supported, it will save in this
format. Otherwise, it will save in the alternative format which you should define.

As input, Watermark Sense accepts all the image formats natively supported
by the operating system. The saving options enable you to use Watermark Sense
for batch image format conversion. To use Watermark Sense for this purpose
(without watermarking), just apply an empty text watermark. Then choose the
desired output image format when saving.

Copyright c©2013-2014 VeprIT. All rights reserved.
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Chapter 4

Additional Image Operations

4.1 Rotating Images
To rotate images by 90◦ either left (counterclockwise) or right (clockwise), select
them in Browser and do one of the following:

• Click the Turn Left or Turn Right button above the Browser.

• Press Cmd + [ or Cmd + ] on the keyboard.

• Use the Image→ Turn Left or Image→ Turn Right menu item.

• Use the corresponding Trackpad gestures.

• Use the context menu on selected images.

To rotate images by 180◦, select them in the Browser and do one of the fol-
lowing:

• Click the Rotate 180◦ button above the Browser.

• Press Cmd + U on the keyboard.

• Use the Image→ Rotate 180◦ menu item.

• Use the context menu on selected images.

Note that these are batch operations. All the selected images are rotated, not
only the one shown in preview.

Copyright c©2013-2014 VeprIT. All rights reserved.
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4.2 Flipping Images
To flip (mirror) images horizontally or vertically, select them in the Browser and
do one of the following:

• Click the Flip Horizontally or Flip Vertically button above the Browser.

• Press Shift + Cmd + [ or Shift + Cmd + ] on the keyboard.

• Use the Image→ Flip Horizontally or Image→ Flip Vertically menu item.

• Use the context menu on selected images.

Note that these are batch operations. All the selected images are flipped, not
only the one shown in Preview.

4.3 Batch Image Metadata Editing

Figure 4.1: Metadata editing panel.

Watermark Sense has an inte-
grated batch image metadata (EXIF
and IPTC) editor. In the Small
Batch mode (see Section 3.1), se-
lect one or more images, and
open the metadata panel using
the Window → Image Informa-
tion and Metadata menu (or press
Cmd + i, or use the corresponding
button above the Browser). Re-
member that changes are applied
to all the selected images!

Most probably you are only in-
terested in editing general infor-
mation such as filename at the
General tab and the author and im-
age information at the IPTC tab.
Data at the EXIF tab are normally
read-only. However, if you really
know what you are doing, you can
also edit the EXIF data. Enable
the checkbox at the bottom of the
EXIF tab for that. This can be par-
ticularly useful if, for example, you do not wish to have any camera information
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in the published images. For your convenience, there are also several buttons to
clear all or most of the metadata at the General tab.

If you are using some metadata fields in your watermark text, make sure to up-
date the Preview manually (by changing the shown image) after you edited these
metadata fields. For performance reasons Preview is not automatically updated on
all the metadata changes.

4.4 Filtering Images
To filter (search) images shown in the Browser, enter the search criteria in the

Filter Images field above the Browser. Only images whose
filenames contain the entered string will be displayed. The search is not case-
sensitive.

To disable the filter, do one of the following:

• Click the cross button within the Filter Images field .

• Click the Filter Images field with the mouse to set the input focus there, and
press the Esc key on the keyboard.

• Search for an empty string.

4.5 Removing Images
To remove images from Watermark Sense, select them in the Browser and do one
of the following:

• Click the Remove Images button .

• Press Delete on the keyboard.

• Use the File→ Remove Selected Images menu item.

Note that with this, you only remove images from the Watermark Sense Browser.
The image files on the disk remain untouched.
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Chapter 5

Additional Topics

5.1 Manual Watermark Positioning Synchronization
Watermark Sense allows to copy & paste (synchronize) the manual watermark
position adjustment between images. This is convenient when the batch configu-
ration cannot define the place you want to use for multiple images.

To copy the manual positioning adjustment from an image, select it in the
Browser (only one image must be selected) and do one of the following:

• Click the Copy Manual Positioning for Current Preset or Copy Manual Po-

sitioning for All Presets toolbar button .

• Press Cmd + Opt + Shift + C or Cmd + Shift + C on the keyboard.

• Choose the Image→ Copy Manual Positioning for Current Preset or Image
→ Copy Manual Positioning for All Presets menu item.

Then select the target images (one or more images to which you want to apply
the same positioning). Do one of the following to paste the settings:

• Click the Paste Manual Positioning toolbar button .

• Press Cmd + Shift + V on the keyboard.

• Choose the Image→ Paste Manual Positioning menu item.

The previously copied positioning will be applied to all the selected images.
Note that you can copy the manual positioning either for the current watermark

preset (Quick Preset in the Single mode, or preset selected in the Applied Presets
list in the Presets mode), or for all watermark presets.
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5.2 Presets Management
To define custom watermark presets, use the Window→Watermark Presets Man-
agement menu, or press Shift + Cmd + P. You can also click the Manage Presets
button or double-click a watermark preset in one of the lists on the Presets tab.

To define custom saving presets, use the Window→ Saving Presets Manage-
ment menu, or press Option + Cmd + P. You can also run the Saving Presets
Management panel from the Save Multiple panel, click the Saving presets button
and choose Manage presets from the menu.

Figure 5.1: Watermark presets manage-
ment window

Use the buttons at the bot-
tom left to create new presets

, remove them , and dupli-
cate existing presets ( , useful to
quickly create a new preset based
on an existing one). You can also
export selected presets and im-
port previously exported presets

. If you want to export all
your presets, do not forget to se-
lect them all first (click inside the
presets list and press Cmd + A).

It is possible to edit multiple
presets at once: select them all
and edit what you wish. You can
reorder presets in the list using
drag&drop (they will also be reordered at other places). When no presets are
selected, you will be prompted to import example presets.

5.3 Resize Sense Integration
Watermark Sense is designed as a companion application for our flexible batch
image resizer/cropper Resize Sense. They are mutually integrated to act as a sin-
gle application, while keeping things so simple and straightforward as possible.
Together they form a flexible and efficient image processing toolset for web pub-
lishing and similar needs.

When done with watermarking, you can open selected (or all) images in Re-
size Sense for resizing and/or cropping. There are special commands in the File
menu for this purpose. Resize Sense will open these images as though they were
originally opened there: the full image quality will be retained, and Resize Sense
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will know where the original files are.
In a similar way you can open Resize Sense output images for watermarking

in Watermark Sense.
Note that this integration is fully functional with Resize Sense 1.6.0 and later.

Earlier versions may also open the images, but they will not delete the generated
temporary files, and will not know the original images’ location.

5.4 Mac App Store version limitations
There is a slight difference between the Watermark Sense version distributed at the
Watermark Sense web page and on the Mac App Store. Due to the Application
Sandboxing mechanism limitations, which are enforced at the Mac App Store, its
version cannot save files at arbitrary locations. It can only save at locations explic-
itly pointed to by the user with the system Save dialog. This slightly affects the
Save Multiple panel functionality, which appears when you save multiple images.
The following limitations are present in the Mac App Store version:

• There is no option to save at original location, because this location is likely
to be blocked by the Application Sandboxing mechanism.

• The last used output directory is not memorized, because it can be blocked
after the application is closed. The user selects the target directory every
time when saving multiple files. This limitation is relaxed on the latest Mac
OS systems supporting security-scoped bookmarks.
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